Trusted Apps Dashboard Login is Failing

Incident Report for 1EdTech Consortium

Resolved

Internal server host has stabilized. APIs are fully restored.
Posted Sep 01, 2026 - 13:57 EDT

Monitoring

Internal server host is experiencing degraded server availability and performance leading to login and API failures throughout TAMS. Users are now able to login while we monitor for stability.
Posted Sep 01, 2026 - 11:59 EDT

Investigating

We are investigating the issue with the Trusted Apps Dashboard.
Posted Sep 01, 2026 - 11:06 EDT
This incident affected: TrustEd Apps Management Suite (TAMS) (TrustEd Apps Admin, TrustEd Apps Dashboard).